Visual Studio 2010 Load Testing Overview

The following is a brief overview of performing a basic load test using Visual Studio 2010 Ultimate:

Launch Visual Studio 2010 Ultimate:

- e —

a icrosoft Visual Studio 2010
h—;__-—_—ﬂ

Designer

) 3

..... :| Calculator

TE-' Fiddler2
»

All Programs

| Search programs and files 2 |

Blofole

Select File -> New Project:

on Start Page - Microsoft Visual Studic (Administrator)

File

| @ Mew Project...

Ctrl+Shift+N
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Select under Visual C# -> Test -> Test Project -> name the project and click OK:

New Project

Recent Templates | NETF Kd - [ ay: [ Befauli
Installed Templates

| SearchInstalled Templates

Type: Visual C#
@ Test Pioject Visual C# L
M project that containe tects

© Visual Basic
4 Visual C#
Windeows
Web
o Uthice
Cloud
Reporting
© SharePoint
Sitverlight
Test
WCF
Workflow
 Visual C++
- Visual F#
o Other Project Types
¢ Database
Mudeling Prujecls
© TestProjects

Online Templates

MName: TestPraject]]

Location: chusers\oneillkmdocuments\visual studio 20104Projects - Browse...

Solution name: TestProjectl Create directory for solution
Add to source control

Click OK if this message displays — in this case | had already existing Tests cached:

You have made changes to your tests |E|

Changes to your tests are no longer automatically displayed. Click Refresh to display your
changes in the Test View or Test List Editor.

Do not show this dialeg box again

OK
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In this case we are going to perform a simple web performance test — so thus click the Unittestl.cs and
delete it:

4[5 TestProjectl
b Properties
b References

#] Uni™

ﬁ Open
Open With...
View Code
&3 View Class Diagram
Exclude From Project
# Cut Ctrl+X
— 52 Copy Ctrl+C
X Delete Del
Rename
“ Properties Alt+Enter
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Right mouse click the Project and select Add -> Web Performance Test:

@ TracefAndTestlmpact.testsettings

4 | TestProj-—-t.
. Prop| 4 Build
B Refer Rebuild
Clean
Run Code Analysis
Calculate Code Metrics
w1 MNew Test... Add »
] Mew em. Ctrl+Shift+4 Add Reference...
Existing ftem... Shift+Alt+ A Add Service Reference...
4 Mew Folder &3 View Class Diagram
o2 Unit Test... Set as StartUp Project
——— Y Load Test.. Debug 3
-| 'f'_g Web Performance Test... | %  Add Solution to Source Contral...

At the browser window that comes-up the Record will already be selected — therefore go to the web
application and perform the desired functionality that is to be tested — when done — click Stop:

=

Web Test Recorder

x

I]I] Pause Stc-p|"[:_:']|><

Go to your Web site to start recording.
Recorded requests will be shown here.
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Now we will run a load test against the web performance test that was created. Therefore right mouse

click the project and select Add -> Load Test:

4[] TraceAndTestimpact.testsettings

4 |8 TestProiacs
[» Pro ke Build
4 [ Refe Rebuild
- Clean
- Fun Code A i
- un Code Analysis
-3 Calculate Code Metrics
] Mew Test... Add
5] Mew Item... Ctrl+Shift+ A Add Reference...
Existing Itemn... Shift+Alt+ 4 Add Service Reference...
4  Mew Folder é%, Wiew Class Diagram
w2 Unit Test... Set as StartUp Project
— % Load Test... | Debug

A wizard comes up — and therefore read each option carefully — at the first screen after reading the

information click Next:
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" New Load Test Wizard X

Welcome to the Create New Load Test Wizard

This wizard will walk you through the steps to create a load test that contains:

Scenario
Load Pattern A load test scenario to which you will add tests.
Test Mix Madel A load pattern, test mix, browser mix and nfetwmk mi?{.
) Counter sets for target computers frem which you will collect performance data.
Test Mix Run settings such as the duration of your test and a description.
Metwork Mix . . . . . .
_ When you have completed the wizard and clicked Finish, a load test is generated in the test project.
Browser Mix You can add additional scenaries and edit the test in the Load Test Editor.
Counter Sets
. For more information press F1 to select a related Help topic.
Run Settings

Click Next to proceed.

< Previous “ Mext = ] [ Finish ] I Cancel
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One can name the load test scenario and select the desired think time profile — when done click Next:

New Load Test Wizard (B S

Edit settings for a load test scenario

Welcome Enter a name for the load test scenario:
| Scenaio

Load Pattern
Test Mix Model Think time profile
Test Mix () Use recorded think times
Metwork Mix @ Use normal distribution centered on recorded think times
Browser Mix ) Do not use think times

Counter Sets

Run Settings

Think time between test iterations: seconds

<Previous |[ Nea> | [ Finish | [ Concel
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The user count can be entered and when done click Next:

New Load Test Wizard |2 e

E_i Edit load pattern settings for a load test scenario

Welcome Select a load pattern for your simulated load:
Scenario @ Constant Load:
— 5]
User Count:
Test Mix Model &r-oun Hser
Test Mix (©) Step load:
Network Mix Start user count: O seers
Browser Mix
P Step duration: o E seconds
ounter
Run Settings Step user count: users/step
Maximum user count: 4 E USErs

<Previous || Ned> || Finsh || Cancel
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A test mix can then be selected if desired —in this case the default settings were selected:

MNew Load Test Wizard

"=  Selectatest mix model for the load test

Welcome How should the test mix be modeled?
Scenario
@ Based on the total number of tests
Load Pattern
_ (7 Based on the number of virtual users

Test Mix () Based on user pace
Metwork Mix () Based on sequential test order
Browser Mix

Counter 5ets

Run Settings

http://www.kmo.name

-
S

141,
4
HILRL

&
A

Ee kB
!

This medel of test mix determines which test is run
when a virtual user starts a test iteration. At the end of
the load test, the number of times that a particular test
was run matches the assigned test distribution. Follow
this model when you are basing the test mix on
transaction percentages in an IS leg or in production
data.

<Previous || Net> | [ Fnish | [ Cancel
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At the ‘Add tests to a load test scenario and edit the text mix’ Wizard screen — select Add:

oo e

Add tests to a load test scenario and edit the test mix

Welcome Add one or more tests to the mic

Scenaric Test Name % | Distribution & Add... ]
Load Pattern

Test Mix Model I
e

Metwork Mix

Browser Mix

Counter Sets

Run Settings

Total 0

<previous || Ned> | [ Finsh || Cancel
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Select the desired test that is desired and select the arrow to move it to be a selected test — then click
OK:

Add Tests T

(i) 0 test(s) added

Select test list to view: Selected tests:
/All Loaded Tests - Test Name Project D
Available tests:

Test Name Project D

B WebTestl TestProjectl

0K Cancel

http://www.kmo.name oneillwebsite@verizon.net Page 11


http://www.kmo.name
mailto:oneillwebsite@verizon.net

Notice that once added with success the 0 test(s) added is now 1 test(s) added — click OK:

-
Add Tests

(i) 1 test(s) added

Select test list to view:

JAll Loaded Tests

Available tests;

Test Name

Project

1

Allv]

Selected tests:
Test Mame Project i
o | WebTestl TestProjectl st
€| i I 3
ok || Cancel

http://www.kmo.name

oneillwebsite@verizon.net

Page 12


http://www.kmo.name
mailto:oneillwebsite@verizon.net

Click Next

¥
[""7]  Add tests to aload test scenario and edit the test mix
Welcome Add one or more tests to the mix
Scenario Test Name % | Distribution a [ Add... ]
Load Pattern WebTest1 w0l |0 Remove
Test Mix Maodel
e
Metwork Mix
Browser Mix
Counter Sets
Run Settings
Total 100
<previous || Net> |[ Finish || Cancel
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At the ‘Add network types to a load test scenario and edit the network mix’ — select your desired choice
—in this case Dial-up 56K Modem was selected — then select Next:

Mew Load Test Wizard

[SeA==)

Add network types to a load test scenario and edit the network mix

Welcame Add one or more network types to the mix and specify a distribution:
Scenario Network Type % | Distribution s || Add |
Load Pattern S
100 .
_ O o |
Test Mix Model LAN
s -
e s —
| Cable-DSL 384Kbps
Browser Mix Cable-D5L 768Kbps
CDMA
CouRiSESes I ;- .o 56k Modem
Run Settings Intercontinental slow WAN 300 Kbps
| Intercontinental WAN 1.5 Mbps
Intra-continental WAN 1.5 Mbps
Total 100
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At the ‘Add browser types to a load test scenario and edit the browser mix’ select the desired Browser
Type — in this case — Internet Explorer 8 was selected then select Next:

New Load Test Wizard (>

Add browser types to a load test scenario and edit the browser mix

Welcome Add one or more browser types to the mix and specify a distribution:

Scenario Browser Type % | Distribution - I Add ]
Losd Petern TR T — L e 1] | r—
Test Mix Model Internet Explorer 7.0
— EE
AT | Firefox 3.0

SRR irteretExplorer 55
Counter Sete Internet Exglorerﬁ.ﬂ

Run Settings Metscape 6.0
| PocketIE3.02
Safari 3

Safari for iPhone
—— Smartphone

Total 100

<Previous || Net> | [ Finish || Cancel
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At the ‘Specify computers to monitor with counter sets during load test run’ —in this case Next was
selected — however if so desired counter sets could be set-up and run:

New Load Test Wizard el
Specify computers to monitor with counter sets during load test run
Welcome Selected computers and counter sets will be added to the default run
Scenario SRR
Lead Pattern Computers and counter sets to monitor: Preview selections:
Test Mix Model -4 Controller Computer
Test Mix L7 LoadTest
N I B SR g Controller
Network Mix =4 Agent Computers
Browser Mix @ Agent
Run Settings
Add Computer... l I Remowve ] Computer Tags: | |
| <Previous || Nea> || Fnish || canca |
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At the ‘review and edit run settings for a load test’ under Load test duration 1:00 was entered then
Finish selected:

MNew Load Test Wizard

a,lﬁ_i Review and edit run settings for a load test

Save Log on Test Failure:

Validation level:

http://www.kmo.name

Welcome Specify the length of the load test by:

Scenario @ Load test duration
Load Pattern Warm-up duration (hh mm ss): | 0 El | HE| | 0 E|
= M?I it Run duration (hh mm ss): | UEl | 10 E| | UE|
Test Mix
Metwork Mix () Test iterations
Browser Mix Test iterations:

Counter Sets Details

_ Sampling rate: seconds
Description:

True -

High - inveke all validation rules

7]

< Previous ” Mext >

[ Fnish || Concel |
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Select the Run Test found under the .loadtest that was created:

LoadTestl loadtest >

WebTestl webtest

Test L

2 Counter Sets

@ LoadTest
-—u H Ly S | PR

..... @ Constant Load Pattern

Eventually a Graph view of the test is displayed and one can view the desired format — by selecting the

Tables tab if so desired :

LeacTess, T2l Pt x RN
\d Ftop 14 Graphs | = Tables
1) Tt in progress Warr Up Remeining: 10:15 E .I
CountEre Key Ind cators 'HPaqe Fesponze Time B
1l o] Dveral .
@ £ Scenarizl nn o i oo [
@ B Campiters - i
o I’E T 0000 OCL) D02 0030 [04C O00SD Q1) Ol OLZ0 13T OLW 3D ﬂZW: XN W10 020 X 4 X3 010 W) I QL3 140 0L EX
Syaler unaden Tesl « || Controler and Lgerts -
l/
00 SOL ez
Owverdew o000 OCL0 DOEC O30 DOwC OOED OO0 010 OL30  CISC OL4D  OXSD 0200 0000 010 O30 DOSC OO0 0030 OO0 0L CIZC QLD CI®C OLED  OED0
4 Configuratizn = | Ceuntzr Instance Lakzgeony Lomputer Crlor Harge Min Mex Avg Last
E.':lntr:.-llcr Lozal run EIE T Key Indicators -
Sampling Rete 413 o] L Luaid Tolel LuedTabSesnari P1-UT-DMEILKM ——a— 2 H ] 3 8 Bl
“ “"“”"“_ vl Pagositec _Totzl LozdTzstfage P W7 OMELKKM —=—— 0 C ] ] ]
LIRS TTSR ol Aug. Pege Tinme Tulel LocdTatFage  PRUT-OMEILKN ——a— @
Requestfec 0 - vl Errors/Szc Totel LocdTzstEnors P WG JMEILKW —=—— g C 0 0 0
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This shows the table view:

LoacTestl T: PR, a0 EIELNERG MR Wzh t Tzst List Editor Source Zontrol Explorer
@ Stop s Grephs [T Teblzs | Tl e L0 K ] v | e
I Toast mprogroas.. L2 threshold visletions Remainng (9403 W |
Crimters Tests -
& [ Doerdl Tesl Seenariv Toldl Passal Feiledd TerlafSes Tel Tims Last Tesl Tirme
1 = Scerariol WebTestl Scenanicl 60,032 €0,032 a SIE o007 000000
" 54 Comcuters
& £ Lrors
Lmars -
o ¥pe Subtype LCourt Lest Message
i
Teval 0
4 Configuration -
Zontrzllzn Lezalrun 3
sempling Hate WAl 1
a Mequests
Tolel Rezuesls a
fezuertsiSec a e

In either view the Errors tree can be selected and the desired items can be viewed:

- AR

[+4] Errors/Sec

4] Exceptions

|4 Extraction Rule Errors
i+ Hittp Errors

[+ Requests Timed Out

L4 Threshold Violations/Sec
[+ Total Errors

|4 Validation Rule Errors

Additionally — from the .loadtest tab — the Open and Manage results can be selected:

LoadTestl.loadtest > QUSRS a U024 Test List H

i) g

=3 Scenarios | Open and Manage Results i
E|L|_;] Scenariol

Y st i
- ys] [100%] WebTestl

i = Brovscar Wi
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One would then select the desired loadtest and click Export:

3/1/2012 2:23 PM 00:05:00 Compl.. LoadTestl

The results can be saved as a .ltrar file:

File name: | - |
Save as type: | Load Test Resuilts Archive(*.ltrar) |
(~ Hide Folders | save || Cancel |

After naming the file and clicking Save — the following is displayed:

Exporting Load Test Runs “

Exporting load test run(s) to a load test un archive. ..

The results can then be viewed later if needed.
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